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Boson NetSim Overview
The Boson NetSim® Network Simulator®, which includes the Boson Router Simulator, is unique compared to all 
others on the market because of the functionality it supports and its features. NetSim utilizes Boson’s proprietary 
Network Simulator, Router Simulator, and EROUTER software technologies, along with the Boson Virtual Packet 
Technology engine, to create individual packets. These packets are routed and switched through the simulated 
network, allowing NetSim to build an appropriate virtual routing table and simulate true networking. Other 
simulation products on the market do not support this level of functionality.

NetSim simulates a wide variety of Cisco® routers, including the 2500 series, 2600 series, 2800 series, and 
3600 series routers, as well as the Cisco Catalyst® 1900 series, 2900 series, and 3500 series switches. NetSim 
supports multiple routing protocols, including RIP, IGRP, EIGRP, BGP, and OSPF. It supports different LAN/
WAN protocols, including PPP/CHAP, ISDN, and Frame Relay. The labs in NetSim require only the devices and 
functionality included with NetSim—they do not require access to any external router or switch hardware. NetSim 
supports many, but not all, of the IOS commands available on a physical router or switch. All of the commands 
referenced in the available labs are supported by NetSim.

Achieving Cisco CCNA® or CCNP®-level certification is the goal of many people who use this product. The 
Boson NetSim covers several Cisco certifications: CCNA (200-301), ENCOR (350-401), and ENARSI (300-
410). The included labs guide you through the configuration of routers, switches, and workstations in a variety of 
scenarios.

Labs are made available (unlocked) depending on the version of NetSim available to you. All labs are kept up 
to date regardless of which NetSim product is owned; however, only the labs that have been unlocked with the 
product purchased are available to you. For example, if you start your studies with a CCNA product, you will have 
the command set and labs available that are necessary to study for that exam. When you are ready to study for 
either the ENCOR or the ENARSI exam, you will need to purchase a new product; NetSim will unlock more labs, 
and a larger command set will become available.

Each NetSim product unlocks a selection of labs. Some lab packs are delivered by NetSim to support other 
products that are sold separately. If you have questions about locked labs, please contact support@boson.com.

After you load and complete an unlocked lab, you can use the grading function in NetSim to grade the lab so that 

https://www.boson.com/support/NetSim-Support-Topics.html
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you can determine whether you completed it correctly. As you progress through the labs, you can master the skills 
needed to pass the simulation questions in the Cisco certification exams. NetSim has the ability to guide and 
grade, and using it for practice can be more helpful than using real routers and switches. NetSim allows you to 
gain experience without requiring you to purchase expensive equipment.

Using NetSim to Prepare for Your Certification
By using NetSim to help you achieve a Cisco certification, you can learn and master the skills necessary to help 
you successfully complete your certification track. The purpose of NetSim is to help you with the practical, hands-
on portion of your education and to ensure that you not only understand the concepts of routing but can actually 
configure and implement routing on Cisco devices.

Mastering Cisco networking involves two fundamental tasks:

1.	 Learn the theory of routers and switches.
2.	 Gain the hands-on experience of implementing that theory by configuring the devices in a network and 

testing them in a lab.

Self-studying for a Cisco certification can be a daunting task. The amount of information a CCNA candidate is 
required to know and the skills that candidate is required to possess are quite extensive. To begin learning the 
theory of configuring a network, you can find a good reference book or listen to an instructor. (Boson Training, 
www.boson.com/boson-training, offers a full slate of classes and Bootcamps.) But a reference book might not be 
enough. The book will not give you the practical, hands-on experience of routing and switching that you can learn 
from NetSim—experience that will help you build on the theoretical knowledge you learned from the reference 
book.

Real equipment gives you the ability to practice on physical routers and switches, but it also is a very costly way 
to practice and leaves a lot of room for error. The Boson NetSim, on the other hand, is an excellent tool to help 
you prepare for the CCNA-level (www.boson.com/certification/CCNA) and CCNP-level  
(www.boson.com/certification/CCNP) exams. NetSim simulates the behavior of a network and does not just return 
preprogrammed responses to expected command inputs. It allows you to create virtual packets and virtual frames 
that will be routed and switched through the simulated network. Aside from physically plugging in the cables and 
listening to the fan noise, your experience with the simulated network will be much the same as your experience 
with a fully functional lab rack without the expense of the hardware. NetSim will enable you to practice various 
configurations and master helpful skills.

Once you feel you have mastered both the theory (www.boson.com/boson-training) and the practical labs  
(www.boson.com/netsim-cisco-network-simulator), you can test your knowledge by using the Boson ExSim-Max 
practice exam products available at the ExSim-Max home page (www.boson.com/exsim-max-practice-exams). 
Boson ExSim-Max products include complex multiple-choice questions, drag-and-drop questions, and custom 
simulation questions.

The Boson NetSim Network Simulator is the most comprehensive product on the market for learning how to 
configure a Cisco router. The Boson NetSim will not only help you become certified, it will help you learn and 
understand how to configure routers, switches, and networks.

www.boson.com/boson-training
https://www.boson.com/boson-training
www.boson.com/certification/CCNA
https://www.boson.com/certification/ccna
www.boson.com/certification/CCNP
https://www.boson.com/certification/ccnp
www.boson.com/boson-training
https://www.boson.com/boson-training
www.boson.com/netsim-cisco-network-simulator
https://www.boson.com/netsim-cisco-network-simulator
www.boson.com/exsim-max-practice-exams
https://www.boson.com/exsim-max-practice-exams
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Contact Information
EMAIL:	 support@boson.com
PHONE:	 877-333-EXAM (3926)
	 615-889-0121
ADDRESS:	 25 Century Blvd. Ste. 401
	 Nashville, TN 37214

Copyright © 1996 – 2022 Boson Software, LLC. All rights reserved. NetSim software and documentation are 
protected by copyright law.

NetSim Technical Support
•	 To review NetSim support topics, go to the NetSim Products Support Topics page  

(www.boson.com/support/netsim-support-topics).
•	 To submit a support ticket, use the navigation bar and select Help > Open Support Ticket. 

License Solutions
•	 Single-User License Agreement (SULA) – You can review the SULA here (www.boson.com/sula#netsim).

Getting Started
After you purchase a NetSim Online product, log in to your Boson account. Once logged into your Boson account, 
you may access NetSim Online directly at netsim.boson.com. You may also access your online products by going 
to the My Products tab on your My Account page.

System Requirements
•	 Supported operating systems: Windows 11, Windows 10, Windows 8, Windows 7, MacOS 10.10+, or a 

Debian based Linux
•	 A web browser that supports JavaScript ECMA 6

o	 Chrome 75+

o	 Firefox 70 +

o	 Safari 6.2.8

o	 Etc.

Begin a Lab
To begin an unlocked Boson NetSim lab, perform the following steps:

1.	 In the Labs pane on the left, select the lab you want to open and click to open the selected lab. 
2.	 To open and run the selected lab, select Lab > Load Lab from the navigation bar or click the Load Lab 

button. Alternatively, you may double-click the title of a lab in the Labs pane to load a lab.
3.	 Click the Lab Document tab to view the the lab’s objectives and instructions. Follow the steps in the Lab 

Tasks section to complete the lab. 
4.	 When you finish, click Lab > Grade Lab from the main menu to ensure that you have successfully 

completed the lab.
5.	 You can choose to save your configurations by selecting the appropriate Save option from the File menu.

mailto:support@boson.com
http://www.boson.com/support/NetSim-Support-Topics.html
https://www.boson.com/support/NetSim-Support-Topics.html
www.boson.com/sula
https://www.boson.com/sula#netsim
https://netsim.boson.com/
https://boson.com/Account/MyProducts
https://boson.com/Account/Default.aspx
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Menus
The menu options in NetSim enable you to easily navigate through the labs, the Consoles section, and more.

Menu Bar
The menu options in NetSim enable you to easily navigate through the labs, the Consoles section, and more.

File Menu

Open
This option enables you to select a file to open. The supported file extensions are *.lab and *.bsn.

Save
This option enables you to save your current lab or topology and configurations. Files are saved with the *.lab 
or *.bsn extension.

Save As
This option enables you to save your current lab or topology and configurations. Files are saved with the *.lab 
or *.bsn extension.
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Preferences Menu
Selecting Preferences opens a tab from which you can configure your user experience, including layout and 
color schemes.

View Menu
The options in this menu tree enable you to alter the way you view the windows and panes within NetSim.

Lab Document
Cick this option to open the related lab document in a new tab.

Lab Topology
Click this option to open the related lab topology in a new tab.

Devices
After you start a lab, select a device from this list; a new browser tab that contains the console for the selected 
device will open. For example, clicking Console Router 1 will open a new tab in your browser showing the 
console of Router 1. 
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Lab Menu
This menu tree enables you to perform all the functions you need once a lab is loaded.

Load Lab 
After you select a lab from the navigation pane, click this option to load the lab instructions, topology, and 
configurations.

Grade Lab
After you have completed a lab, click this option to verify that you have completed the lab successfully.

End Lab
After you have completed a lab, click this option to end the lab.

Help Menu
The options in this menu tree enable you to find out more information about the Boson NetSim Network Simulator 
and how to find support if you need it.

User Manual
This option opens the Boson NetSim User Manual, the document you are reading now, which guides you 
through the features and functionalities of NetSim.

Create Support Ticket
This option allows you to submit a ticket through your Boson.com account  
(www.boson.com/Account/SupportTickets).

Quick Start Guide
This option opens the Quick Start Guide.

About NetSim
This option displays basic information about NetSim, including the version and company information. You can 
also display the License Agreement from this page.

Activate Keys
This option opens the Activate Keys tab. From here, you can activate additional versions of NetSim not 
already associated with your Boson.com account and view versions that are already associated with your 
account.

User Menu ( )
Icons in the Quick-Launch toolbar are enabled or disabled depending on the pane in use.

Boson.com
This option navigates to Boson’s homepage (www.boson.com).

My Account
This option navigates to your Boson account (www.boson.com/Account).

My Tickets
This option allows you to view your existing support tickets and to submit a new support ticket through your 
Boson account (www.boson.com/Account/SupportTickets).

Logout
This option logs you out of NetSim.

https://www.boson.com/Account/SupportTickets
https://boson.com/default.aspx
https://www.boson.com/Account/
https://www.boson.com/account/supporttickets
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Tabs

Home
Once you launch NetSim via your standard web browser, the Home tab will be available. From this tab, you can 
review the Quick Start Guide, open the User Manual (this document), view any recent labs, and view support 
materials. You can also read the latest announcements for new features and products.
 

Lab Preview
When you click a lab in the Labs section, the Lab Preview tab opens and displays the lab description, the 
topology of the lab, and your lab history for that lab. Here, you can click the Load Lab button to start or continue 
the lab.
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Lab Document
When you load a lab, the Lab Document tab opens. You can scroll through the instructions as you work through 
the lab. If desired, you can view this document in a separate tab by clicking View > Lab Document.

You can search the lab instructions by clicking within the document area and pressing the Ctrl+F key combination.

Lab Topology
When you load a lab, the Lab Topology tab opens. The topology displayed shows the devices that are loaded 
into the network for the current lab. You can double-click on any device shown in this tab to open a console for the 
selected device.
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Consoles
After you have loaded a lab, you can view the device consoles and begin performing the lab steps. You will see 
the console window for each device that is currently open.

From the console window, you can modify the devices and perform the steps in the lab’s instructions. By default, 
only one device console is opened when a lab is loaded. You can access additional device consoles in the lab by 
selecting View > Devices device name menu, by clicking the console button ( ) next to a device in the Devices 
pane, or by double-clicking the device on the Lab Topology tab. To begin performing the lab steps on a device, 
you should select the console for that specific device. Note that clicking View > Devices device name while the 
lab is loaded will open the console for a device in a separate browser tab.

You can paste configuration commands to a device from another application. For example, if you have typed a 
series of commands in a program such as Notepad and would like to add them to a device’s configuration, copy 
the commands you typed. Then, in NetSim, right-click within the device’s Console pane and press Enter. The 
device will then quickly execute the commands.

In addition, you can copy console output or commands that you have entered in a device’s configuration in 
NetSim by pressing the left mouse button and dragging the cursor to select the text you wish to copy. When you 
release the left mouse button, the text you selected will be copied to the clipboard. Note: The copy/paste feature 
is not supported on FireFox due to web browser security restrictions.
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Labs
The Labs pane contains a list of labs you can load and a text box to enter text and search the available labs for 
keywords.

Search Labs
You can use the Filter section to search for a specific term within a lab description. 

You can search all of the available labs. For example, if you want to find Network Address Translation (NAT) 
labs, you could type NAT in the search box. You will see labs addressing NAT from the CCNA, ENARSI, and 
ENCOR lab packs. 

Note that although a search might return results from multiple lab packs, only labs from the currently activated 
version of NetSim will be available.

Available Labs
There are over 480 labs in NetSim, and these labs are arranged in specific categories. The lab packs are 
specific to the version of NetSim that you have activated. You can single-click a lab to view the Lab Preview 
tab. To load a lab, double-click the lab or select the lab and click Lab > Load Lab. You may also click the 
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Load Lab button located on the Lab Preview tab. You can expand or collapse the menu items by clicking the 
expander next to each category.

Connections
The Connections pane displays all of the configured connections in the currently active topology. Hovering your 
mouse cursor over one of the connections will display interface information about the link between the devices.

Devices
The Devices pane displays all of the devices in the currently active topology. You may also select a device and 
click the Console button ( ) to access a device’s console while a topology is running.
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Troubleshooting

Can I use key combinations as shortcuts?
The following table contains various shortcut key combinations you can use in NetSim:

Function Key
Console Shortcuts

Move to beginning of line Ctrl+A
Move to end of the line Ctrl+E
Move back one character Ctrl+B
Move forward one character Ctrl+F
Next command Down Arrow Key
Previous command Ctrl+P or Up Arrow Key
Break Ctrl+C
Copy Highlighted text is automatically copied to your 

computer’s clipboard
Paste Right-click to past the contents of the clipboard 

to the console window
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Certification Candidates

Boson Software’s NetSim Network Simulator is designed to simulate a Cisco environment for practice and 
troubleshooting. To learn more about NetSim, please visit boson.com/netsim-cisco-network-simulator or contact 
Boson Software.

Organizational and Volume Customers

Boson Software’s outstanding IT training tools serve the skill development needs of organizations such as 
colleges, technical training educators, corporations, and governmental agencies. If your organization would like to 
inquire about volume opportunities and discounts, please contact Boson Software at orgsales@boson.com.

Contact Information

E-Mail:		  support@boson.com
Phone:		  877-333-EXAM (3926)
		  615-889-0121
Fax:		  615-889-0122
Address:	 25 Century Blvd., Ste. 401
		  Nashville, TN 37214

https://boson.com/netsim-cisco-network-simulator
mailto:orgsales@boson.com
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